Browsing articles tagged with "vmwareesxi - Admins Goodies"
Nov 2, 2013
tom

VMware vSphere cluster design for site redundancy

I have a question about the best design for site redudancy when using vSphere clusters. A bit of background info about our situation first though. We are a medium-sized company with two main offices, located in different countries. Our networks are linked by a Layer2 150Mbps leased line which is currently underused. We have a variety of services running for internal use within the company, some on physycal servers and some on existing vSphere clusters. […]

Continue Reading »
Jan 15, 2013
tom

Linux VMware data store larger then 2TB using lvm?

I’me trying to think of the best way to create one logical volumne on a linux VM to be over 2TB. I need to make one logical volume that is 8TB and have access to this amount on the my SAN. I know there is a 2TB limit per VMDK file but was wondering what the best method is to achieve this? I know I can mount all the drives in more virtual environment but […]

Continue Reading »
Jan 1, 2013
tom

How to mount USB on ESXi 4.1?

This is what I tried but it doesn’t work : Connect with SSH # /etc/init.d/usbarbitrator stop # fdisk -l |grep Disk Disk /dev/disks/mpx.vmhba40:C0:T0:L0: 4022 MB, 4022337024 bytes # ls /dev/disks/mpx.vmhba40:C0:T0:L0* /dev/disks/mpx.vmhba40:C0:T0:L0 /dev/disks/mpx.vmhba40:C0:T0:L0:4 # mkdir /mnt/usb # mount /dev/disks/mpx.vmhba40:C0:T0:L0 /mnt/usb mount: mounting /dev/disks/mpx.vmhba40:C0:T0:L0 on /mnt/usb failed: No such file or directory Also tried with /dev/disks/mpx.vmhba40:C0:T0:L0:4, with /mnt/usb/, always the same error message. Then I checked # ls -l /vmfs/volumes, but it wasn’t there either The version […]

Continue Reading »
Dec 20, 2012
tom

How to mount vmdk inside ESXi 5.0 console

I have some big files inside VM which I need to copy to ESXi host datastore. What is the best/fastest method? Right now I am using vSphere Client inside the VM. VM is running in virtual network with another VM acting as a router to the outside world. As ESXi has different public IP than te router, traffic goes out to the physical network switch and back in over the same NIC. This is connected […]

Continue Reading »
Dec 17, 2012
tom

Checking for orphaned snapshots – ESXi5

So we had some issues with our passive mail node over the weekend doing vmtools updates and to resolve a problem we had to revert to a snapshot and then reseed all the databases across. All in all everything seemed fine, the server works and CCR copy status is running fine. I used the “Delete All” option this morning to remove the snapshot and the process according to vCenter has completed with no errors and […]

Continue Reading »
Dec 12, 2012
tom

Issues migrating a CentOS 4 xen guest to VMWare

I am migrating a xen guest. It is running a CentOS 4. I am using the same steps that have worked in the past for our RHEL5 and RHEL6 based systems but for some reason, I’m getting errors. Here are the steps in brief: On the guest, install a non-xen kernel and the kernel’s devel package. Turn off database and other services that may cause data inconsistencies Using VMWare vCenter Converter, migrate data to VMWare […]

Continue Reading »
Dec 9, 2012
tom

What happens with the Guest OS’s on ESXi in the event of a power failure? [closed]

It seems like this question should be answered easily, but my google-fu may not be up to snuff. I am a hobbyist ESXi user/ freelance developer/ systems engineer. I don’t have my ESXi server on a UPS. If I am away from home, and my house experiences a power outage, the ESXi server is set to come back on automatically when power is restored. What happens with the guest OS’s? Ideally I would like them […]

Continue Reading »
Nov 23, 2012
tom

PAT with IPTABLE over Virtual NIC in a virtual machine

I have a strange problem and i cannot find a solution. So first, here is my config; i have got an ESXI with public IP : 1.1.1.1, i host a virtual Ubuntu server with one NIC (configured in my esxi) eth0 with public IP 2.2.2.2, and i have plugged a virutal nic eth0:0 with public IP 3.3.3.3. Here is my /etc/network/interfaces: auto eth0 allow-hotplug eth0 iface eth0 inet static address 2.2.2.2 netmask 255.255.255.255 broadcast 2.2.2.2 […]

Continue Reading »
Nov 22, 2012
tom

vmware not getting ip on dell r620

Installed a new ESXi 5.1 on a new Dell R620 When connecting to the iDrac (Enterprise) from the dedicated iDrac connection I can see 1 NIC connected (beside the integrated jack) The problem is that when launching the server, the ESXi is NOT getting an IP – it shows as loop back IP DHCP is enabled Tried to restart management network What’s next? Asked by Saariko VMware usually takes DHCP from the first nic. From […]

Continue Reading »
Nov 21, 2012
tom

VMWare ESXi – VPN Tunnel to VMs

We are looking at renting a VMWare ESXi server through a provider. This VMWare ESXi server will be allocated a public IP. Most of the VMs that we will host on this server is only meant to be used internally. My question is if it would be possible to set up a VPN tunnel (ipsec) from the gateway in our office (Cisco RV082) to the VMWare host server so that we do not have to […]

Continue Reading »
Pages:1234567...50»