Browsing articles tagged with "yum - Admins Goodies"
Jul 11, 2013
tom

How do I upgrade to the latest PHP version in CentOS with yum?

I found some blog posts about this, but it’s rather lack of descriptions on possible side effects. I could really use some detailed on these steps: How to add a repo that provides PHP 5.4 into yum Can this seamlessly replaces the current PHP version in CentOS? How can I switch back to the official repo when it supports PHP 5.4? (current 5.3.3 in my system) Will there be any potential to break PHP modules […]

Continue Reading »
Jun 9, 2013
tom

How to install Apache Benchmark on CentOS?

I try to install Apache Benchmark using Is there a way to install Apache Bench (ab) without installing apache solutions on my centos but when i run yumdownloader httpd, i get error: root@local [~/httpd]# yumdownloader httpd Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: yum.phx.singlehop.com * elrepo: repos.lax-noc.com * extras: centos.tcpdiag.net * updates: mirror.stanford.edu No Match for argument httpd Nothing to download What is it? and how can i fixed it? Edit […]

Continue Reading »
Mar 22, 2013
tom

cannot use any yum command: no space left on device

if i use any yum command, i get Loaded plugins: fastestmirror Traceback (most recent call last): File “/usr/bin/yum”, line 29, in <module> yummain.user_main(sys.argv[1:], exit_code=True) File “/usr/share/yum-cli/yummain.py”, line 285, in user_main errcode = main(args) File “/usr/share/yum-cli/yummain.py”, line 114, in main base.doLock() File “/usr/lib/python2.6/site-packages/yum/__init__.py”, line 1791, in doLock while not self._lock(lockfile, mypid, 0644): File “/usr/lib/python2.6/site-packages/yum/__init__.py”, line 1861, in _lock os.write(fd, contents) OSError: [Errno 28] No space left on device If i use the top command i see […]

Continue Reading »
Mar 4, 2013
tom

Best Practices for updating a previously unmaintained server RHEL5.7

A new RedHat EL5.6 server has been recently put under my care. It is immediately obvious that, for the previous 12 months, little to no attention has been given to any sort of package updates. Typically I am of the mindset of if it isn’t broke – don’t fix it. However, after registering the server with RHN, and also using the yum-security plugin to check security updates, there are just over 1100 “security” updates available. […]

Continue Reading »
Jan 16, 2013
tom

yum install obsolete openoffice instead of libreoffice

Unfortunately the software that I’m using (Alfresco) requires the installation of openoffice, and not libreoffice. If I try and configure it to use libreoffice I receive errors during startup. If I try to install any of the openoffice packages: yum install openoffice* I receive errors for all packages similar to: Package openoffice.org-langpack-bg_BG is obsoleted by libreoffice-langpack-bg, trying to install 1:libreoffice-langpack-bg-3.4.5.2-16.el6.x86_64 instead Then it proceeds to try and download libreoffice. I don’t see anything in man […]

Continue Reading »
Jan 15, 2013
tom

Yum Hangs on “Setting up repositories”

When running the following command, yum hangs on Setting up repositories. [vagrant@centos48 yum.repos.d]$ sudo yum install emacs Setting up Install Process Setting up repositories yum.conf [vagrant@centos48 ~]$ cat /etc/yum.conf [main] cachedir=/var/cache/yum debuglevel=2 logfile=/var/log/yum.log pkgpolicy=newest installonlypkgs=kernel kernel-smp kernel-devel kernel-smp-devel kernel-largesmp kernel-largesmp-devel kernel-hugemem kernel-hugemem-devel distroverpkg=centos-release tolerant=1 exactarch=1 retries=20 obsoletes=1 gpgcheck=1 plugins=1proxy= [intentionally not listed]# PUT YOUR REPOS HERE OR IN separate files named file.repo # in /etc/yum.repos.d CentOS-Base.repo Note that I got the same error as before […]

Continue Reading »
Dec 19, 2012
tom

Specifying a source in puppet doesn’t seem to work

I have been attempting to create a manifest for installing postgres 9.1 using puppet on a Centos 5 server. I have been trying to adapt the instructions at http://wiki.postgresql.org/wiki/YUM_Installation in order to achieve this and when I go through a manual process, I have been able to. It would seem to me therefore that a puppet manifest containing package { ‘postgresql91-server’: ensure => installed, source => ‘http://yum.postgresql.org/9.1/redhat/rhel-5-x86_64/pgdg-centos91-9.1-4.noarch.rpm’ } however on attempting to apply this manifest […]

Continue Reading »
Nov 7, 2012
tom

Install PHP 5.3 on Centos 6

I am setting up a staging server using CentOS and need to install PHP 5.3 to mirror my production server. Using the standard yum install php I’m sure will give me 5.4 – I’ve had a look and can’t figure out how to specify a version number to install. Can anyone advise? Many thanks. Asked by bsod99 To specify a version you do: yum install php-5.3.3-14 This assumes that php-5.3.3-14 is available in the repos […]

Continue Reading »
Oct 28, 2012
tom

Centos 6.3 install reiserFS support

I’m trying to change an existing ext4 partition to reiserFS in Centos 6.3 64bit. I’ve updated the kernel to Centos Plus: First, I’ve updated /etc/yum.repos.d/CentOS-Base.repo: In the [centosplus] section: enabled=1 includepkgs=kernel* Then I ran yum ypdate and my Kernel was updated to Centos Plus: [root@vappsil disk]# uname -r 2.6.32-279.11.1.el6.centos.plus.x86_64 Then, I’ve added this to /etc/yum.repos.d/CentOS-Base.repo into the [centosplus] section: includepkgs=kernel* jfsutils reiserfs-utils into the [base] and [updates] section: includepkgs=kernel* jfsutils reiserfs-utils But when trying to […]

Continue Reading »
Oct 21, 2012
tom

Puppet yum repo – Pull down 2.7.x vs 3.0.x

So a few weeks ago I started on the path to using puppet to automate all the configs/services. At the time I was using the EPEL repo, which installed version 2.6.x. After some reading I was trying to gain access to the flatten method available via the puppet stdlib, and thought it was available by default in the newer 2.7.x version. So I added a puppet repo with the following settings: [puppetlabs] name=Puppet Labs Packages […]

Continue Reading »
Pages:1234567...24»